lucascavalheiro
Joined: 22 Sep 2009
Posts: 2
mjau-mjau, thanks for your fast reply.

I have tried 3 different e-mail accounts with NO success. Contact form says "sent" but nothing arrives to my inbox. :roll:

update: my web server is www.freehostia.com. If someone is experimenting the same problems please post here.


Re: "Could not mail" on some servers.
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7759
Feel free to provide me with admin login and I will test it out for myself.

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


Re: "Could not mail" on some servers.
alberto
Experienced
Joined: 24 Apr 2007
Posts: 120
pain wrote
To use contact form, first check:
1. Config>Settings>Email>[x] AllowEmail is enabled
2. Config>Settings>Email>OwnerEmail is correct

If you have an issue 'Could not mail':
Here is small test for email functionality on your server.

http://imagevuex.com/emailtest.php *
Success: imagevuex.com OK

*Please don't abuse it, I'm getting email every time.

All it does - tries to email to me.

1. Download http://imagevuex.com/emailtest.zip
2. Unzip and upload to your server
3. Try http://yoursite.com/emailtest.php
4. If it says OK - then email should work. (Mention your site name if it doesnt.)
5. If it FAILS - paste link to your emailtest in a message to your host support.

FAIL means something is misconfigured on server and function mail just... not mails. Which can be resolved only by your admin.

We're having test suite in or list too.


I made the test and it's ok, . I have no error message but the "send " buttom doesn't work.and I realised the same happens to me on others people imagevue x2 galleries . when I move the mouse over the button it's like I don't see it...
actually after few attempts it works, but I heve to go over the button with the mouse and move it slowly and carefully to find the right place where to click. this happens with other galleries too, then I found http://www.mikeivers.com/web/#/content/zcontact/ and there it works perfectly.


Re: "Could not mail" on some servers.
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7759
works here... What browser/OS are you using?

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


Re: "Could not mail" on some servers.
alberto
Experienced
Joined: 24 Apr 2007
Posts: 120
mjau-mjau wrote
works here... What browser/OS are you using?


firefox with xp pro
I checked now and with explrer it works perfectly


contact form still not working
exelone
Joined: 12 Nov 2007
Posts: 16
New York City
Hello Karl,

Tried the changes you suggested
-allowEmail: is on
-ownerEmail: has correct email address (used hotmail and yahoo accounts)
Contact form says that the message is sent, but still no success.
Also checked my web host and they are using
Built-in extensions: .php, .php3, .phps, .php5
PHP Mode: php_php5 (php_libphp5)

Using latest version of imagevueX V2.6
Any suggestions?

Quote
May I add an issue here that seems to be very frequent for many users - Some servers are set up so they are not allowed to send emails to emails on the same domain as the server is on. Meaning: If you have mywebsite.com, your server may be obstructing you from sending to [email protected]. I have seens this quite frequently, so I recommend checking it.
How to check it?
If you don ´t already have a free webmail account like gmail, hotmail or yahoo, then please sign up for one(they are free). Then, add your webmail email as ownerEmail in settings. Finally, try to send an email from contactform - Are you receiving it at your webmail? If yes, then your server/host has the restriction mentioned above. You need to email them and ask them if they can change their policy, or if they have any workarounds ... Imagevue can ´t solve this(unless you can use external webmail to receive emails from contactform).


Re: contact form still not working
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7759
exelone wrote
Hello Karl,

Tried the changes you suggested
-allowEmail: is on
-ownerEmail: has correct email address (used hotmail and yahoo accounts)
Contact form says that the message is sent, but still no success.
Also checked my web host and they are using
Built-in extensions: .php, .php3, .phps, .php5
PHP Mode: php_php5 (php_libphp5)

Using latest version of imagevueX V2.6
Any suggestions?

I don't know, but if you have a link we could take at look at least ... Could you also provide admin login, and send it to pain in a private message along with the link to your gallery, and a link back to this forum topic so we know what its about.

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


Re: "Could not mail" on some servers.
exelone
Joined: 12 Nov 2007
Posts: 16
New York City
Thanks Karl.
Sent a message to pain and awaiting response.

Here is the link to the contact form that is nor working:

http://alexbitar.com/#/content/zcontact/


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
Unfortunately I can't help here, emails are just not leaving your server, right now I can only recommend to send a message to your hosting provider support and ask them about this issue.

We have plans for SMTP emails support though.

_________________
Nick / Phuket, Thailand


Re: "Could not mail" on some servers.
exelone
Joined: 12 Nov 2007
Posts: 16
New York City
Hello Pain,

Emails are leaving the server. I am able to access emails on the server and it gets forwarded to an earthlink account. Also the php test is working.

If you would like to try a test send me an email at:
[email protected]

It's the contact form that isn't working. It doesn't forward anything, mails just go into the ether.

Look forward to your help in this matter
Thanks
Alex


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
I mean emails sent from php using mail() function, not just any email. We'll try to fix up smtp emails for you, though.

I've also sent a support request to your hosting provider, will see what they have to say about this.

_________________
Nick / Phuket, Thailand


Re: "Could not mail" on some servers.
exelone
Joined: 12 Nov 2007
Posts: 16
New York City
Success!
The PHP you gave works like a charm. It bypasses the mailbox from the server and forwards it to my other emails address (hotmail and earthlink).
Thank you for this help!


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
So, we're putting SMTP support to production and next update will remedy this forever.

_________________
Nick / Phuket, Thailand


Re: "Could not mail" on some servers.
User avatar
Experienced
Joined: 19 Dec 2009
Posts: 146
Chengdu, PRO China
I had that glitch with contact mail, when I changed my 'home' page, using a different contact form and other stuff, I now get contact mail to my gmail account almost instantly.. so I can't think that the problem is server-specific ??


Re: "Could not mail" on some servers.
User avatar
Joined: 27 Aug 2010
Posts: 11
Salzburg, Austria
sorry, but the error i got all the time (never worked) is:

SMTP Error: Could not connect to SMTP host

tried couple of versions, double checked, but unfortunateley always the same result

any ideas ?

pls. help

Thomas
http://www.salzburger.me/iv/

PS: your emailtest.php went OK


cron
 
Imagevue Forums HomeForum  View topic - "Could not mail" on some servers.55 posts