User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
To use contact form, first check:
1. Config>Settings>Email>[x] AllowEmail is enabled
2. Config>Settings>Email>OwnerEmail is correct

If you have an issue 'Could not mail':
Here is small test for email functionality on your server.

http://imagevuex.com/emailtest.php *
Success: imagevuex.com OK

*Please don't abuse it, I'm getting email every time.

All it does - tries to email to me.

1. Download http://imagevuex.com/emailtest.zip
2. Unzip and upload to your server
3. Try http://yoursite.com/emailtest.php
4. If it says OK - then email should work. (Mention your site name if it doesnt.)
5. If it FAILS - paste link to your emailtest in a message to your host support.

FAIL means something is misconfigured on server and function mail just... not mails. Which can be resolved only by your admin.

We're having test suite in or list too.

_________________
Nick // Imagevue

Image
Image
Image
Image

dear-apple.com jaconda.im indexr gridpapr


Re: "Could not mail" on some servers.
djoko
Joined: 23 Feb 2009
Posts: 1
pain wrote
To use contact form, first check:
1. Config>Settings>Email>[x] AllowEmail is enabled
2. Config>Settings>Email>OwnerEmail is correct

If you have an issue 'Could not mail':
Here is small test for email functionality on your server.

http://imagevuex.com/emailtest.php *
Success: imagevuex.com OK

*Please don't abuse it, I'm getting email every time.

All it does - tries to email to me.

1. Download http://imagevuex.com/emailtest.zip
2. Unzip and upload to your server
3. Try http://yoursite.com/emailtest.php
4. If it says OK - then email should work. (Mention your site name if it doesnt.)
5. If it FAILS - paste link to your emailtest in a message to your host support.

FAIL means something is misconfigured on server and function mail just... not mails. Which can be resolved only by your admin.

We're having test suite in or list too.


Result in my web:

Success <website.com> OK.

But, the email is not send to owner... ? Why ?
I have a hosting for my website with webmail from gmail not frrom hosting.
This MX Entry is set to gmail.

Please help... sory for my bad english... ;)


COULD NOT MAIL
User avatar
Experienced
Joined: 27 Jan 2007
Posts: 28
I have a similar problem, I suggested the test and (ok) but does not work with my domain when I use my domain of the following error message COULD NOT MAIL


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
We use php mail() function, so we are totally host-dependent, and this should be forwarded to your support. Sometimes they just disable it.

This is the easiest method to send emails. Zero config on most servers in the world. It just works (or doesn't).

_________________
Nick // Imagevue

Image
Image
Image
Image

dear-apple.com jaconda.im indexr gridpapr


Re: "Could not mail" on some servers.
sanatist
Joined: 8 Jan 2009
Posts: 5
Hello,

I have a problem with my contactform.. It says, that the mail is sent, but I don't receive anything. I tried different mail adresses and checked the spamsettings and spamdirectories, but nothing..

Then I 've testet the emailtest.php and it gives an OK.
It worked with an earlier version of imagevue 2x, I think it was the December 2008 version. I tried to reupload and overwrite again, but it still doesn't work. I don't get an error message and no mails.


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
This is something on your side, for example your ip might end up in some spam db because somebody else hosted on the same shared server with you was banned. Its not because of something we added in code. Try to contact your hosting support on this issue.

But don't be sad yet. We have some improvements planned for future versions and you will be able to use your smtp mail account.

_________________
Nick // Imagevue

Image
Image
Image
Image

dear-apple.com jaconda.im indexr gridpapr


Re: "Could not mail" on some servers.
mananetwork
Experienced
Joined: 22 Sep 2008
Posts: 32
Vancouver, British Columbia
I had someone mention they've sent me a couple emails in the past that I never received. I think after I upgraded to a newer version of X2 this became a problem.

In the past I had received a bunch of email to my hotmail domain, but it just stopped working(maybe after upgrade?). I switched to a gmail address and quickly fired out a test email. It came in successfully.

I would like to use my hotmail account, how do I fix this?


Re: "Could not mail" on some servers.
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7658
mananetwork wrote
I would like to use my hotmail account, how do I fix this?

I can say immediately, this is nothing we have any control over. Unfortunately, hotmail and google have their spam filter policies, and sometimes they are more likely to sort an email as spam if it is sent from a server emailer.

Additionally, this may be related to your domain name AND server host/IP in general. Hotmail will check up the incoming emails server/domain, and consider the credibility by comparing email vs domain vs server IP.

We had a lot of trouble with this ourselves, and integrated an SPF record which helped a little.

Did you check if the email lands in your hotmail spam filter? If so, you can check it as "NOT spam" and it will start appearing in your inbox.

All I can say is that as long as it is sending an email, we have no control over how they are received. We can only "send" it ...

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
But we're having SMTP integration in the list of 'future things' so maybe this'll get resolved one day.

The problem with those options is that there are too many already and we still need more.

_________________
Nick // Imagevue

Image
Image
Image
Image

dear-apple.com jaconda.im indexr gridpapr


Email in contact form disappears into the ether
exelone
Joined: 12 Nov 2007
Posts: 16
New York City
I've updated to the latest version of ImagevueX2.1.3.3 from V1.7 and I 'm also having an issue with the contact form. It says that the email is sent but it doesn't go into any email address, just disappears into the ether. I've tried the http://imagevuex.com/emailtest.php * and also get the success response. I've spoken with the hosting provider and they are saying that its something with the software. Email php is active, so is there any other setting I should check for?

Alex


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
You should probably download email test http://imagevuex.com/emailtest.zip and try it on your server.

If they say mail works, let em try it after you upload. Also try different email addresses, sometimes mail is banned from certain servers to certain emails, or sometimes just not leaving server at all.

_________________
Nick // Imagevue

Image
Image
Image
Image

dear-apple.com jaconda.im indexr gridpapr


email contact form not working
exelone
Joined: 12 Nov 2007
Posts: 16
New York City
Hello Pain,
Thanks for the advice. Tried several things but still having problems with contact form:

Downloaded http://imagevuex.com/emailtest.zip and ran the test. Got this response (Success: alexbitar.com OK)

Disabled the contact from. Cleared cache and enabled it again.

Added new email account to strictly receive emails from the contact form. The email is on the webhosts site. Also, have it going to an earthlink account and nothing gets forwarded. If I send an email directly to that address it works. But through the contact form, nothing.

Is there anything that I'm missing?

Alex


Re: "Could not mail" on some servers.
User avatar
Imagevue Hitman
Joined: 2 May 2006
Posts: 2883
What do you mean directly? From email client? Ofcourse it would work, emails aren't leaving your site, this is something you should bug your support with.

Email test is just couple of lines of code just in case somebody from support will tell "that is software problem". There is just mail() function, so its easy to see what's going on.

_________________
Nick // Imagevue

Image
Image
Image
Image

dear-apple.com jaconda.im indexr gridpapr


Re: email contact form not working
lucascavalheiro
Joined: 22 Sep 2009
Posts: 2
exelone wrote
Hello Pain,
Thanks for the advice. Tried several things but still having problems with contact form:

Downloaded http://imagevuex.com/emailtest.zip and ran the test. Got this response (Success: alexbitar.com OK)

Disabled the contact from. Cleared cache and enabled it again.

Added new email account to strictly receive emails from the contact form. The email is on the webhosts site. Also, have it going to an earthlink account and nothing gets forwarded. If I send an email directly to that address it works. But through the contact form, nothing.

Is there anything that I'm missing?

Alex


Exactly the same here. Any sugestion?


Re: email contact form not working
User avatar
Imagevue Wizard
Joined: 30 Sep 2006
Posts: 7658
lucascavalheiro wrote
exelone wrote
Hello Pain,
Thanks for the advice. Tried several things but still having problems with contact form:

Downloaded http://imagevuex.com/emailtest.zip and ran the test. Got this response (Success: alexbitar.com OK)

Disabled the contact from. Cleared cache and enabled it again.

Added new email account to strictly receive emails from the contact form. The email is on the webhosts site. Also, have it going to an earthlink account and nothing gets forwarded. If I send an email directly to that address it works. But through the contact form, nothing.

Is there anything that I'm missing?

Alex


Exactly the same here. Any suggestion?

May I add an issue here that seems to be very frequent for many users - Some servers are set up so they are not allowed to send emails to emails on the same domain as the server is on. Meaning: If you have mywebsite.com, your server may be obstructing you from sending to [email protected]. I have seens this quite frequently, so I recommend checking it.

How to check it?
If you don ´t already have a free webmail account like gmail, hotmail or yahoo, then please sign up for one(they are free). Then, add your webmail email as ownerEmail in settings. Finally, try to send an email from contactform - Are you receiving it at your webmail? If yes, then your server/host has the restriction mentioned above. You need to email them and ask them if they can change their policy, or if they have any workarounds ... Imagevue can ´t solve this(unless you can use external webmail to receive emails from contactform).

_________________
Karl / mjau-mjau

Image
Image
Image
Image

www.imagevuex.com
www.mjau-mjau.com
www.photogallerylinks.com


 
Imagevue Forums HomeForum  View topic - "Could not mail" on some servers.55 posts